p8pro no spark issue

Discuss which Sensors work best with these ECUs and share how you are using inputs and outputs
kitcar
Posts: 11
Joined: Tue Sep 22, 2020 2:59 pm
ECU Model: P8 Pro

Re: p8pro no spark issue

Post by kitcar »

did you personally have this as a good running setup before it was parked up over that time and know 100% it was never touched
100% never touched the dta from dtawin
Antral
Posts: 193
Joined: Mon Aug 01, 2011 8:20 am

Re: p8pro no spark issue

Post by Antral »

Without doubt something has changed or been changed since you last ran the car, things don't changed on their own.
Antral
Posts: 193
Joined: Mon Aug 01, 2011 8:20 am

Re: p8pro no spark issue

Post by Antral »

Have you tried reloading the Known working Map? Surely you have kept a copy on your PC or a memory stick. This sometimes fixes things if your ecu map has been corrupted.

Tony.
kitcar
Posts: 11
Joined: Tue Sep 22, 2020 2:59 pm
ECU Model: P8 Pro

Re: p8pro no spark issue

Post by kitcar »

The problem is the original map was overwritten when i started entering the ecu as i saved the ecu map b4 i started. I realise i should have renamed it and backup that way to keep history.
Engine now starts but stalls within half a second. Waiting for sparkplugs. Fuelpressure and injectors work so i suspect now its spark plugs.
stevieturbo
Posts: 3271
Joined: Tue Aug 02, 2011 12:08 pm
ECU Model: No ECU
Location: Norn Iron

Re: p8pro no spark issue

Post by stevieturbo »

So the answer to my question twice where you said nothing had changed from it working previously........something had in fact changed.

It is unlikely spark plugs will cause the engine to start briefly, then stall.

More likely it is not getting a suitable amount of fuel/air if you have now confirmed good spark on all cylinders, and at a sensible time.

Try reducing fuel by a lot...then trying to start.
Then gradually increasing a bit at a time until it starts to show some life. That will at least give you a starting point for how much fuel it might want for a cold start.
Antral
Posts: 193
Joined: Mon Aug 01, 2011 8:20 am

Re: p8pro no spark issue

Post by Antral »

Oh dear, you really should save your original working map/s, always a base to return to if a problem like yours occurs.
There will be nothing wrong with the P8Pro.
Seen it so many times.

Tony
kitcar
Posts: 11
Joined: Tue Sep 22, 2020 2:59 pm
ECU Model: P8 Pro

Re: p8pro no spark issue

Post by kitcar »

stevieturbo wrote:So the answer to my question twice where you said nothing had changed from it working previously........something had in fact changed.

It is unlikely spark plugs will cause the engine to start briefly, then stall.

More likely it is not getting a suitable amount of fuel/air if you have now confirmed good spark on all cylinders, and at a sensible time.

Try reducing fuel by a lot...then trying to start.
Then gradually increasing a bit at a time until it starts to show some life. That will at least give you a starting point for how much fuel it might want for a cold start.
Ive just changed the fuel pump as the old one was stuck due yo 3years standing and the old petrol was bad so i have drained fuelystem. The new pump is a cheap aftermarket bosch type.. ive got no fuel pressure gauge but will install one to see if i get around 3 bar fuelpressure which i believe should be ok. I got inline filters fittet before and after the pump. There is a lot of pressure on the fuelrails as i noticed when cleaning the injectors. It might be too much but than the factoy inline pressure regulater may not work although return line throws fuel back in tank.
stevieturbo
Posts: 3271
Joined: Tue Aug 02, 2011 12:08 pm
ECU Model: No ECU
Location: Norn Iron

Re: p8pro no spark issue

Post by stevieturbo »

And now even more has changed....

3 year old fuel would be a bad starting point, so absolutely it needs fresh fuel.

I thought you had already confirmed you had fuel ? But if you're saying the fuel pump is "stuck".....that must not have been the case ?

And lets hope you've used suitable filters...many do not.
kitcar
Posts: 11
Joined: Tue Sep 22, 2020 2:59 pm
ECU Model: P8 Pro

Re: p8pro no spark issue

Post by kitcar »

To be clear the first thing i did beforebstarting in the first place was drain all fuel and renew the pump filters and fresh fuel before starting. Than i cleaned injectors and tested them too.
Post Reply