MSD coil pack

Discuss which Sensors work best with these ECUs and share how you are using inputs and outputs

Re: MSD coil pack

Postby MGFMINI » Fri Feb 07, 2020 1:02 pm

Hi Rob,
No problem and as I am seeing RPM on both real time screen in Ecu and on Race Technology dash (so done something right) assuming ECU is seeing trigger signal, albeit in the wrong place. Got so distracted with ensuring the coils were firing on the correct pins etc I didn’t think to invert them.... hopefully will be the answer!
MGFMINI
 
Posts: 54
Joined: Thu May 05, 2016 6:39 am
Location: Somerset, UK
ECU Model: P8 Pro

Re: MSD coil pack / Injectors

Postby MGFMINI » Sat Feb 15, 2020 9:57 am

Good afternoon,
After swapping coils over and back several times, double checking my wiring etc etc I have found the following.....

With the plugs out and cranking the engine over I am getting spray from injectors on Cylinders 1 and 3 (None on 2 and 4)
After swapping the injector plugs I then spray on cylinders 2 and 4....proving injectors are all ok

After checking my wiring again....all correct so
ECU output 1 (pin 37) Cyl 1
ECU output 2 (pin 18) Cyl 3
ECU output 3 (pin 36) Cyl 4
ECU output 4 (pin 54) Cyl 2

So baffled I dug out the old harness that came with the (used on a Peugeot 308 I think) P8 ECU and found the following
ECU output 1 (pin 37) wire linked and running Cyl's 1 & 3
ECU output 2 (pin 18) wire linked and running Cyl's 4 & 2
ECU output 3 (pin 36) linked to ECU output 4 (pin 54) within the ECU plug

Seems coincidental that the injectors that I cannot get to spray are the same that were linked on the old harness, so surely injecting on the on one cylinder with both valve closed....although the coils are wasted spark and sparking on the opposing stroke surely the above is doing the same on the injection.

This would lead me to think that there is a problem within the ECU on the injector drivers / switching transistors on 36 and 54
MGFMINI
 
Posts: 54
Joined: Thu May 05, 2016 6:39 am
Location: Somerset, UK
ECU Model: P8 Pro

Re: MSD coil pack

Postby Rob Stevens » Sat Feb 15, 2020 11:07 am

I had 2 injector drivers fail on my P8, in your situation as you say looks like outputs 3 and 4 have failed. I think you have a few options here.

1. Send it back to DTA for test and repair - I repaired my own ecu with new drivers from DTA as I needed all 8 drivers
2. Wire all the injectors to outputs 1 and 2
3. Try using outputs 5 and 6 - This would be my preference

I assume they didn't work in test mode either, would point to something else if they did. Check you don't have twin injectors selected in general engine settings.
Rob Stevens
 
Posts: 1108
Joined: Thu Jul 28, 2011 4:10 am
ECU Model: S100 Pro
Distributor: None-Coil On Plug :)

Re: MSD coil pack

Postby MGFMINI » Sat Feb 15, 2020 12:07 pm

Hi Rob,
Well I temporarily wire it as the above just to try it (Cant do any more damage) and it fired straight up...Im amazed and not sure I understand how, very loud and smokey, not a bad thing but wonder of it will run correctly as is
Not sure if they ran in test mode, but not when cranking
Twin injectors not ticked in the program, had already checked that
Guess this would be the best option, Would outputs 5 and 6 be injecting at the correct time?

If not I will speak to Alex and see if they can repair it


Thanks Rob
MGFMINI
 
Posts: 54
Joined: Thu May 05, 2016 6:39 am
Location: Somerset, UK
ECU Model: P8 Pro

Re: MSD coil pack

Postby Rob Stevens » Sat Feb 15, 2020 12:29 pm

All the injectors fire all together when not in sequential.
Try it on the other outputs.
And well done by the way, most satisfyingly once it runs.
Rob Stevens
 
Posts: 1108
Joined: Thu Jul 28, 2011 4:10 am
ECU Model: S100 Pro
Distributor: None-Coil On Plug :)

Re: MSD coil pack

Postby Rob Stevens » Sat Feb 15, 2020 12:48 pm

Was this with the coils wired seemingly incorrect ie output 1 to cylinders 2 and 3 ?
Rob Stevens
 
Posts: 1108
Joined: Thu Jul 28, 2011 4:10 am
ECU Model: S100 Pro
Distributor: None-Coil On Plug :)

Re: MSD coil pack

Postby MGFMINI » Sat Feb 15, 2020 1:41 pm

Hi Rob,
No strangely not, I tried inverting the coils but was worse, this is with 1&4 (and 2&3 in original positions as per P8 wiring diagram and injectors temp wired as above!
So 96 degs BTDC , and started almost instantly
MGFMINI
 
Posts: 54
Joined: Thu May 05, 2016 6:39 am
Location: Somerset, UK
ECU Model: P8 Pro

Re: MSD coil pack

Postby Rob Stevens » Sun Feb 16, 2020 3:17 am

Weard, so why would the sensor position change with the S series.
Rob Stevens
 
Posts: 1108
Joined: Thu Jul 28, 2011 4:10 am
ECU Model: S100 Pro
Distributor: None-Coil On Plug :)

Re: MSD coil pack

Postby stevieturbo » Sun Feb 16, 2020 5:03 am

Rob Stevens wrote:Weard, so why would the sensor position change with the S series.


S series can run missing tooth anywhere

P series cannot. Pretty sure P must be less than 90deg.
stevieturbo
 
Posts: 3252
Joined: Tue Aug 02, 2011 12:08 pm
Location: Norn Iron
ECU Model: No ECU

Re: MSD coil pack

Postby MGFMINI » Sun Feb 16, 2020 5:49 am

Thanks both, Yes was very satisfying indeed as the whole car has been built from the ground up with parts from various places (engine included) I have fabricated the rest, wiring loom etc etc, I was going to to just run a standard used engine but over the last 4 years things have (Much to my long suffering wife's disgust) it morphed into everything with the exception of the rocker cover being sourced, both new and used. Also first time building a K Series engine with all its weird quirks so was wondering what the hell I had wrong, just glad I had the old loom to look at as led me to the fault.

The injectors are not set sequential so will try 5 and 6, but will I have to increase the number of cylinder within the software to eight for example or are they all operating regardless?

Will get a strobe on it and find the exact number of degrees BTDC at some point, and check the cam lift again
MGFMINI
 
Posts: 54
Joined: Thu May 05, 2016 6:39 am
Location: Somerset, UK
ECU Model: P8 Pro

PreviousNext

Return to Sensors, Inputs, and Outputs

Who is online

Users browsing this forum: No registered users and 5 guests