Car wont rev (map problem)

This section is dedicated to discussion of DTA engine control units such as the DTA E48 EXP, P8 Pro, DTA S40, S60, S80, and S100, as well as all things ECU related.

Car wont rev (map problem)

Postby Totalnova » Tue Jun 16, 2020 8:03 am

Edit, some background on the engine .
1.8 vauxhall Nova z18xe running dta s40 with individual throttle bodies, basic sensor set up and I have a wide band fitted

I'm having some issues getting the car to a drivable state,
It starts and idle okish but when revved it wont go past 3500rpm its like it hit a limiter and misfires, I cant get around it by half throttling or anything.
If you could have a look at my base map and give some suggestions on any changes i can make would be grateful.

Image

Image

Image
This is a fresh build and has never run properly
On a side note I've changed coil pack and plugs and I'm going to replace the ignition leads as well to rules these out, any help is welcome.
Cheers Nick
Totalnova
 
Posts: 17
Joined: Sun Apr 29, 2018 7:04 am
ECU Model: S40 Pro

Re: Car wont rev (map problem)

Postby Antral » Tue Jun 16, 2020 8:19 am

Is the Crank wired correctly?
Sometimes an engine will run but have like a false limiter
On a Vauxhall crank sensor the pin outs are :-

Pin 1 - signal
Pin 2 - sensor ground
Pin 3 the shield.
It's worth a check a mistake could have happened.

Tony.
Antral
 
Posts: 189
Joined: Mon Aug 01, 2011 8:20 am

Re: Car wont rev (map problem)

Postby JON-TEC-RALLYE » Tue Jun 16, 2020 9:56 am

send error screen, in the center, top, are the stork errors. check wiring as indicated by ANTRAL.
DTA----MoTec----HONDATA
JON-TEC-RALLYE
 
Posts: 28
Joined: Sat Jul 30, 2011 4:35 pm
Location: Canary-Island
ECU Model: S100 Pro
Distributor: JON-TEC-RALLYE
Firmware Version: 89

Re: Car wont rev (map problem)

Postby Alex DTA » Tue Jun 16, 2020 10:28 am

It's the crank sensor on that engine. If you measure the resistance, it will be over 2 kOhms.
Change it for one from one of the other engines.
Alex DTA
 
Posts: 1428
Joined: Fri Feb 28, 2014 1:03 pm
ECU Model: S40 Pro
Distributor: DTA
Firmware Version: 79

Re: Car wont rev (map problem)

Postby Totalnova » Tue Jun 16, 2020 12:21 pm

To be fair I did have this set up running last year albeit with an engine that had issues that I've swapped out. This is a new untested crank sensor. I probably have a spare somewhere. I'll try that and see how I get on.
Cheers
Totalnova
 
Posts: 17
Joined: Sun Apr 29, 2018 7:04 am
ECU Model: S40 Pro

Re: Car wont rev (map problem)

Postby Totalnova » Thu Jun 18, 2020 11:08 am

Crank sensor changed and it now revs freely, I say freely, it still needs to be mapped but its loads better then it was.
Thanks for the help guys.
Totalnova
 
Posts: 17
Joined: Sun Apr 29, 2018 7:04 am
ECU Model: S40 Pro


Return to General

Who is online

Users browsing this forum: No registered users and 6 guests